Date: prev next · Thread: first prev next last
2011 Archives by date, by thread · List index


Hi,


+sal_Int32 GetNumberOfProperties ( const SvxMSDffHandle* pData )

and
+void SetProperties (const SvxMSDffHandle* pData, com::sun::star::beans::PropertyValues&  
rPropValues)

looks ok to me - or maybe ShapePropertiesFromDFF or somesuch, as
set/getProps sounds somehow generic (and is quite heavily overloaded
as a name).

Additionally, please make those methods static (they're only used
inside that file) - and another loosely followed convention is to
prefix those local methods with either "lcl_" or "Impl"/"impl".
So we have:

static sal_Int32 <prefix>GetNumberOfProperties ( const SvxMSDffHandle* pData )

and

static void <prefix>ShapePropertiesFromDFF (const SvxMSDffHandle* pData, com::sun::star::beans::PropertyValues& rPropValues)

with <prefix> = "lcl_" or "[Ii]mpl" - is one of these prefices more modern than the others? What about indentation and formatting of if/then/else or switch statements? Any rules?
Though that's a matter of taste ... ;)
That's why I've asked for review  :-)

Christina

Context


Privacy Policy | Impressum (Legal Info) | Copyright information: Unless otherwise specified, all text and images on this website are licensed under the Creative Commons Attribution-Share Alike 3.0 License. This does not include the source code of LibreOffice, which is licensed under the Mozilla Public License (MPLv2). "LibreOffice" and "The Document Foundation" are registered trademarks of their corresponding registered owners or are in actual use as trademarks in one or more countries. Their respective logos and icons are also subject to international copyright laws. Use thereof is explained in our trademark policy.