Chr. Rossmanith wrote:
I've found two duplicate code with simian and moved it into two new methods which saves 229 lines of code. It would be nice if someone could review the patch and at least suggest better names for the methods...
Nice, good work -
@@ -104,6 +104,118 @@ using namespace ::com::sun::star::lang; using namespace ::com::sun::star::beans; using namespace ::com::sun::star::drawing; + +void rSegInfo_nSDat_method (EnhancedCustomShapeSegment& rSegInfo, sal_uInt16 nSDat)
ShapeSegmentFromBinary() maybe?
+sal_Int32 GetNumberOfProperties ( const SvxMSDffHandle* pData )
and
+void SetProperties (const SvxMSDffHandle* pData, com::sun::star::beans::PropertyValues& rPropValues)
looks ok to me - or maybe ShapePropertiesFromDFF or somesuch, as set/getProps sounds somehow generic (and is quite heavily overloaded as a name). Additionally, please make those methods static (they're only used inside that file) - and another loosely followed convention is to prefix those local methods with either "lcl_" or "Impl"/"impl". Though that's a matter of taste ... ;) Cheers, -- Thorsten
Attachment:
pgpzsatrRxD3F.pgp
Description: PGP signature