Date: prev next · Thread: first prev next last

Re: Fwd: Re: [sv-users] Utskrift av nollvärden i Libreoffice Calc


Den sön 18 aug. 2019 kl 17:45 skrev Ian Wennerholm <ian@matkull.se>:

Ojojoj.... svarade till fel mottagare.
Såhär ska det vara!

Hej,

jag har en liten fundering:

I LO Calc gör jag formeln OM(A1+B1=0;"";A1+B1)

Detta ger tomma celler där värdet är 0.

Prova!

Problemet med det är ju om man har väldigt många och långa formler. Anta
att du räknar ut något med en massa celler inblandade:
=A1+(B1-C1*D1)*SIN(E1/ROT(3))
Då skulle man behöva skriva:
=OM(A1+(B1-C1*D1)*SIN(E1/ROT(3))=0;"";A1+(B1-C1*D1)*SIN(E1/ROT(3)))
Kopiera nu 10000 rader neråt.
Varje gång värdet inte blev 0 räknas värdet nu ut igen för att kunna
skrivas ut, så i värsta fall sker 20000 uträkningar istället för 10000.
Detta gör ju att det blir betydligt segare.
Man kan givetvis komma runt detta lite genom att använda fler kolumner:
F1:
=A1+(B1-C1*D1)*SIN(E1/ROT(3)
G1:
=OM(F1=0;"";F1)
Sedan döljer man kolumn F för att få det snyggt och prydligt.

Men fortfarande lär det ju bli snabbare att bara använda en kolumn och
istället göra en global inställning som gör att nollvärden inte skrivs ut.

Jag har själv lärt mig den hårda vägen hur lätt det är att göra saker
långsamma utan att först inse det. Jag hade exempelvis någon tabell med ett
stort antal rader där jag ville markera alla rader som hade samma värde som
hela kolumnens maximivärde med grön bakgrund och de rader som hade samma
värde som samma kolumns minimivärde med röd bakgrund. Så hur gjorde jag
det? Jo, jag använde villkorlig formatering och jämförde varje rads värde i
den aktuella kolumnen (låt oss ta D som exempel) med MAX($D$2:$D$10001) och
med MIN($D$2:$D$10001). Så varje cell utförde alltså funktionerna MIN och
MAX på 10000 celler vardera för att sedan formatera cellerna i rätt
bakgrundsfärg.
Det gick otroligt segt och jag kunde inte förstå varför, innan jag insåg
vad jag hade gjort.
Så istället lät jag minimi- och maximivärdena räknas ut av var sin cell, så
jämförde jag cellvärdena med dem istället. Plötsligt var allting
blixtsnabbt.


Vänliga hälsningar

Johnny Rosenberg

Ian
Den 2019-08-16 kl. 12:09, skrev Lars-Göran Hansson:
Svarade person också :-)
skickar till gruppen igen


Verkar vara när jag sparar i xls-format som felet uppstår, jag testade
att spara i ods och då fungerade det. Måste tyvärr skicka filer i xls
ibland då kunden inte har libreoffice utan excel.

Libre Office 6.2.6.2
Windows 10 pro

Den 2019-08-16 kl. 11:04, skrev Johnny Rosenberg:
Den fre 16 aug. 2019 kl 10:22 skrev Lars-Göran Hansson <lg@lgr.se
<mailto:lg@lgr.se>>:

    Ingen som vet hur man gör?


Jag gjorde precis som du skrev och bocken förblev urbockad när jag
öppnade filen igen, så jag kan inte se att det skulle vara något fel.
Har du provat att uppgradera? Min version verkar ju funka i alla
fall. Vilken version kör du?

LibreOffice 6.2.5.2
Manjaro Linux 18.0.4



Vänliga hälsningar

Johnny Rosenberg



    ------

    Jag har skapat en fakturamall där det finns en beräkning på varje
    rad i
    ca 20 rader typ E18 x G18, E19 x G19, E20 x G20 osv.
    Om man inte använder alla rader blir det ingen siffra i beloppsraden
    (har ställt in det i Verktyg - Alternativ - LibreOffice Calc -
    Visa och
    bockat ur Nollvärden)
    När jag inte heller vill ha nollorna utskrivna har jag ställt in
    det i
    Format - Sida - Blad - bockat ut Nollvärden även där

    MEN!!!! när jag sparat och stängt dokumentet och öppnar det igen
    så är
    nollorna tillbaka vid utskrift (bocken kommer tillbaka) men nollorna
    visas inte på skärmen så den första bocken ovan är fortfarande
    urbockad.

    Hur får jag bocken avseende utskrift att alltid vara urbockad??

    Lars-Göran Hansson

    --

    --     For unsubscribe instructions e-mail to:
    users+unsubscribe@sv.libreoffice.org
    <mailto:users%2Bunsubscribe@sv.libreoffice.org>
    Problems?
https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
    Posting guidelines + more:
    https://wiki.documentfoundation.org/Netiquette
    List archive: https://listarchives.libreoffice.org/sv/users/
    Privacy Policy: https://www.documentfoundation.org/privacy



    --     For unsubscribe instructions e-mail to:
    users+unsubscribe@sv.libreoffice.org
    <mailto:users%2Bunsubscribe@sv.libreoffice.org>
    Problems?
https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
    Posting guidelines + more:
    https://wiki.documentfoundation.org/Netiquette
    List archive: https://listarchives.libreoffice.org/sv/users/
    Privacy Policy: https://www.documentfoundation.org/privacy






---
This email has been checked for viruses by AVG.
https://www.avg.com

--
For unsubscribe instructions e-mail to:
users+unsubscribe@sv.libreoffice.org
Problems?
https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/sv/users/
Privacy Policy: https://www.documentfoundation.org/privacy


-- 
For unsubscribe instructions e-mail to: users+unsubscribe@sv.libreoffice.org
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/sv/users/
Privacy Policy: https://www.documentfoundation.org/privacy

Context


Privacy Policy | Impressum (Legal Info) | Copyright information: Unless otherwise specified, all text and images on this website are licensed under the Creative Commons Attribution-Share Alike 3.0 License. This does not include the source code of LibreOffice, which is licensed under the Mozilla Public License (MPLv2). "LibreOffice" and "The Document Foundation" are registered trademarks of their corresponding registered owners or are in actual use as trademarks in one or more countries. Their respective logos and icons are also subject to international copyright laws. Use thereof is explained in our trademark policy.