[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[sv-users] LO-Calc Söka ett cellvärde i många celler


Hej!

Det jag söker är en formel som visar om cellvärden i en kolumn finns i en eller flera andra kolumner. (på samma flik)
Värdena är påhittade, det är sökformeln som är intressant - Alla fält ska behandlas som text.

1) Jag önskar söka värdet i B3, B4och B5 i en kolumn E3-E7
Exempel på underlag .:
B3 = 123456
B4 = 00123
B5 = 1234-56

E3 = 032-456
E4 = 123456
E5 = 654321
E6 = 098734
E7 = 1234-56

(Resultatet ska göra det möjligt att selektera ut de rader som hittas eller inte hittats.)
H3 = Hittad (radnummer eller "1" eftersom värdet finns i E4)
H4 = (tomt eftersom värdet inte finns i E3-E7)
H5 = Hittad (radnummer eller "1" eftersom värdet finns i E7)

2) Önska söka efter C3, C4 och C5 i två kolumner F3-G5
Exempel på underlag .:
C3=123456
C4=876-541
C5=008743

F3=83740-43
F4=23433
F5=123456

G3=008743

(samma här att kunna selektera rader)
I3 = Hittad (radnummer eller "1" eftersom värdet finns i F5 - första kolumnen)
I4 = (tomt eftersom värdet inte finns i F3-G5)
I5 = Hittad (radnummer eller "1" eftersom värdet finns i G3 - andra kolumnen)

_______________________________________________________________________

Bakgrund!
Håller på med två filer med produkter som jag vill jämföra i någon mening.
Original1 innehåller ca 25000rader (20 kolumner)
Original2 innehåller ca 36000 rader (65 kolumner)
Har rensat bort en mängd kolumner.
Nu är Original1 = 6 kolumner och Original2 = 9 kolumner.

Tänkte att detta är enkelt...
Började med denna formel (anpassat efter mitt program och inte exemplet ovan)
=OM(ANTAL.OM(A$2:A$40000;A2)=1;"";ANTAL.OM(A$2:A$40000;A2))
Hade även andra kriterier som
- Alla celler i original1 finns i Original2 (med det gör det inte)
- Tänkte att alla träffar > 1 skulle visas som resultat.

Jag skrev in formeln på 25000rader och väntade och väntade och väntade....
efter 3-4 timmar gav jag upp - inget resultat.... LO fixade inte detta.

Söker en enklare formel, eftersom jag inte är intresserad av antalet träffar...

//Jan



--
For unsubscribe instructions e-mail to: users+unsubscribe@sv.libreoffice.org
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/sv/users/
Privacy Policy: https://www.documentfoundation.org/privacy

Privacy Policy | Impressum (Legal Info) | Copyright information: Unless otherwise specified, all text and images on this website are licensed under the Creative Commons Attribution-Share Alike 3.0 License. This does not include the source code of LibreOffice, which is licensed under the Mozilla Public License (MPLv2). "LibreOffice" and "The Document Foundation" are registered trademarks of their corresponding registered owners or are in actual use as trademarks in one or more countries. Their respective logos and icons are also subject to international copyright laws. Use thereof is explained in our trademark policy.