[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[pl-users] LibreOffice + PostgreSQL (bytea)


W celu przechowywania plików graficznych (JPG) w bazie danych użyłem typ danych BYTEA. Jeżeli chodzi o samą bazę danych nie ma z tym problemu.
W przypadku stosowania sterownika JDBC celem komunikacji LibO z bazą danych zachowanie formularza jest prawidłowe. Jeżeli dodaje
formant za pomocą którego dodaję grafikę do bazy po zamknięciu formularza mam podgląd dodanej grafiki.

Natomiast w przypadku stosowania wbudowanego w LibO sterownika SDBC grafikę mogę dodawać. Niestety podgląd dodanej grafiki
w formularzu mam jedynie do czasu jego zamknięcia. Po ponownym otwarciu formularza grafika jest niewidoczna.
Grafika z pewnością została dodana ponieważ jest ona widoczna w generowanym raporcie jak i również po ponownym otwarciu bazy za pomocą
LibO + sterownika JDBC.

Czy to oznacza, że sterownik SDBC jeszcze poprawnie nie obsługuje typu danych BYTEA czy coś w ustawieniach?

System: Windows 7 HP
LibO: Wersja 3.6.0.4 (Build ID: 932b512)
PostgreSQL: 9.1.4

--
Unsubscribe instructions: E-mail to users+help@pl.libreoffice.org
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/pl/users/
All messages sent to this list will be publicly archived and cannot be deleted

Privacy Policy | Impressum (Legal Info) | Copyright information: Unless otherwise specified, all text and images on this website are licensed under the Creative Commons Attribution-Share Alike 3.0 License. This does not include the source code of LibreOffice, which is licensed under the Mozilla Public License (MPLv2). "LibreOffice" and "The Document Foundation" are registered trademarks of their corresponding registered owners or are in actual use as trademarks in one or more countries. Their respective logos and icons are also subject to international copyright laws. Use thereof is explained in our trademark policy.