[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libreoffice-users] Templates not linked in Writer after update to Xubuntu 18.04


On 10-11-18 21:52, Regina Henschel wrote:
> Hi,
>
> Wiebe van der Worp schrieb am 10-Nov-18 um 20:10:
>> After updating to Xubuntu 18.04 I was quite surprised to find out that
>> ott templates are not linked to documents any more.
>
> It might be, that now the templates are not where the document expects
> it. The information about the template is in a node meta:template in the
> file meta.xml in the document package. [You know, that a document is
> actually a zip-container?]
>
> Now compare, whether the path, which is listed in the file, would go to
> the template in your LibreOffice installation.
>
> Kind regards
> Regina
>
>

@regina, thanks. node meta:template in file meta.xml was not found. I
assume this is what is also shown in File > Properties > Tab General >
Template (?)

No Template Changer AND no linked templates is a show stopper, so back
from 6.n to 5.n and since this did not help much:

Package latest and greatest 5.4.7.2 from
https://downloadarchive.documentfoundation.org/libreoffice/old/

unzipped in ~/Downloads
delete all from ~/.config/libreoffice

sudo su
apt-get remove --purge libreoffice*
apt-get clean
apt-get autoremove
cd ~/Downloads/LibreOffice_5.4.7.2_Linux_x86-64_deb/DEBS/
dpkg -i *.deb

In LO: Tools > Options > Paths > Templates > Added location of custom .ott

When I create a document based on a standard template, template
information is included
Ditto when custom template is used.
When I paste from a source, template information is blanked

Time for Template Changer from
https://www.odfauthors.org/libreoffice/english/resources-for-contributers/template-changer-extension/at_download/file
(1.2.7d)
Installed it
Restarted Writer
Assign Template to new document > select template > Ok and...
Crash of LO

Looping what is before in order to try 5.3.7.2
Same story, except first hanging and then crashing.

So I installed the distro version 6.0.6.2 again without Template Changer.

What I did now, is very carefully paste information from documentation.
Added a field with template information for controlling the link. Part
by part pasted, creating new TOC's, it works without breaking the
template link.

Considering the large amount of documents I maintain, it is all in all
quite frustrating, but with a little progress fortunately.

If I do grep on an unzipped and empty document with template
"template-name", like
grep -r -i "template-name" *
I get only one result in meta.xml

Maybe a stupid question, but does changing template information directly
in meta.xml help in cases where I loose template links? In that case,
BASH doing unzip sed and zip might be a hackish solution.

All suggestions appreciated very much!

--
To unsubscribe e-mail to: users+unsubscribe@global.libreoffice.org
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy

Privacy Policy | Impressum (Legal Info) | Copyright information: Unless otherwise specified, all text and images on this website are licensed under the Creative Commons Attribution-Share Alike 3.0 License. This does not include the source code of LibreOffice, which is licensed under the Mozilla Public License (MPLv2). "LibreOffice" and "The Document Foundation" are registered trademarks of their corresponding registered owners or are in actual use as trademarks in one or more countries. Their respective logos and icons are also subject to international copyright laws. Use thereof is explained in our trademark policy.